Production API Error Elevation - Cloud Provider Issues

Incident Report for Stash Alloy

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:50 EDT

Monitoring

Our cloud provider confirmed there were service outages and have since released a fix. We are monitoring as systems recover.
Posted Oct 20, 2025 - 05:49 EDT

Investigating

Our API integration tests have encountered an increase in errors. We are currently investigating. Stay tuned for updates.
Posted Oct 20, 2025 - 03:16 EDT
This incident affected: Production API and Customer Dashboard.